Day-32: DTP(Dynamic Trunking Protocol).

By | June 12, 2022

DTP is a Cisco proprietary protocol that is automatically enabled on Catalyst 2960 and Catalyst 3560 Series switches. Switches from other vendors do not support DTP. DTP manages trunk negotiation only if the port on the neighbor switch is configured in a trunk mode that supports DTP.

There are 2 dynamic modes available for the switchport mode command:

  1. Dynamic Auto
  2. Dynamic Desirable

Dynamic Desirable.


In dynamic desirable mode, an interface will actively attempt to convert the link to a trunk link. It will become a trunk interface if the neighboring interface is configured in trunk mode, dynamic auto mode or dynamic desirable mode.

When you configure the dynamic desirable, it starts sending the DTP messages on that port.

Dynamic Auto.


In dynamic auto mode, an interface will agree to operate in trunk mode only if the neighboring interface explicitly wants to form a trunk link. It will become a trunk interface if the neighboring interface is configured in trunk mode or dynamic desirable mode.

Normally when you configure the command that switch mode trunk it means that the port is going to become a trunk even if you may have connected to an end host.

When you configure the dynamic auto, it does not initiate the request only responds if the other ends initiate the request then it will respond.

Auto is passive and desirable is Active.

When you configure the switch mode trunk, it also sends the DTP messages and if another end switch is desirable or auto it can become a trunk.

If both sides are AUTO it means that the port can’t become a trunk because no one initiates the request.

But cisco recommends and suggests making the port desirable on both ends.

Trunking Administrative Mode Configuration.

The trunking administrative mode is the mode in which the interface has been configured using the switchport mode command. The trunking administrative mode can have one of the following 4 values

  1. Access.
  2. Trunk.
  3. Dynamic auto.
  4. Dynamic desired.

Trunking Operational Mode .

The trunking operational mode is the mode in which the interface actually operates. This mode is dependent on the trunking administrative mode configuration and DTP negotiation.

  1. Access Port.
  2. Trunk Port.

DTP Command Variation.

  • switchport mode access: Puts the interface (access port) into permanent non trunking mode and negotiates to convert the link into a nontrunk link. The interface becomes a nontrunk interface, regardless of whether the neighboring interface is a trunk interface.
  • switchport mode dynamic auto: Makes the interface able to convert the link to a trunk link. The interface becomes a trunk interface if the neighboring interface is set to trunk or desirable mode. The default switchport mode for newer Cisco switch Ethernet interfaces is dynamic auto. Note that if two Cisco switches are left to the common default setting of auto, a trunk will never form.
  • switchport mode dynamic desirable: Makes the interface actively attempt to convert the link to a trunk link. The interface becomes a trunk interface if the neighboring interface is set to trunk, desirable, or auto mode. This is the default switchport mode on older switches, such as the Catalyst 2950 and 3550 Series switches.
  • switchport mode trunk: Puts the interface into permanent trunking mode and negotiates to convert the neighboring link into a trunk link. The interface becomes a trunk interface even if the neighboring interface is not a trunk interface.
  • switchport nonegotiate: Prevents the interface from generating DTP frames. You can use this command only when the interface switchport mode is access or trunk. You must manually configure the neighboring interface as a trunk interface to establish a trunk link.

DTP Negotiated Interface Modes.

When an interface is statically configured in access mode, it will operate in non-trunking (access) mode. It may participate in DTP negotiation, and if it does so, it will attempt to convert the link to a non-trunk link. Even if the neighboring interface does not agree to operate in access mode, this interface will operate in access mode.

When an interface is statically configured in trunk mode, it will operate in trunking mode. It may participate in DTP negotiation, and if it does so, it will attempt to convert the link to a trunk link. Even if the neighboring interface does not agree to operate in trunk mode, this interface will operate in trunk mode.



AccessDynamic AutoDynamic DesirableTrunk
TrunkTrunkLimitedTrunkTrunk
AccessLimitedAccessAccessAccess
Dynamic AutoTrunkAccessAccessTrunk
Dynamic DesirableTrunkAccessTrunkTrunk
Horizontal values are for “switch 1” and the vertical values for “switch 2”.

DTP port negotiation LAB.

Example-1: Both Side Dynamic Auto.

SW1(config)#interface fa0/14
SW1(config-if)#switchport mode dynamic auto


SW2(config)#interface fa0/14
SW2(config-if)#switchport mode dynamic auto

When both interfaces are configured in dynamic auto mode, the resulting link will operate in access mode.

Example-2:Both Side Dynamic desirable .

SW1(config)#interface fa0/14
SW1(config-if)#switchport mode dynamic desirable


SW2(config)#interface fa0/14
SW2(config-if)#switchport mode dynamic desirable

When both interfaces are configured in dynamic desirable mode, the resulting link will operate in trunk mode. desirable means it initiates the DTP and both interfaces will try to become a trunk.

Example-3: One Side is Dynamic Auto and the other side Dynamic Disarable.

SW1(config)#interface fa0/14
SW1(config-if)#switchport mode dynamic auto


SW2(config)#interface fa0/14
SW2(config-if)#switchport mode dynamic desirable

When one interface is in dynamic desirable and the interface is in dynamic auto, the resulting link will operate in trunk mode. The interface in dynamic desirable mode will actively attempt to convert the link to a trunk link. The interface in dynamic auto mode will agree to operate in trunk mode.

Example -4:One interface in dynamic auto mode and the other interface statically in access mode.

SW1(config)#interface fa0/14
SW1(config-if)#switchport mode access


SW2(config)#interface fa0/14
SW2(config-if)#switchport mode dynamic auto

The interface on Switch 2 is configured in dynamic auto mode and it will initiate the DTP negotiation to select its operational mode. The neighboring interface is statically configured in access mode and will indicate its desire to remain in access mode. As a result, the dynamically configured interface on Switch 2 will operate in access mode.

Example -5:One interface in dynamic auto mode and the other interface is configured statically in trunk mode.

SW1(config)#interface fa0/14
SW1(config-if)#switchport mode trunk


SW2(config)#interface fa0/14
SW2(config-if)#switchport mode dynamic disirable

The interface on Switch 2 is configured in dynamic desirable mode – it will initiate the DTP negotiation to select its operational mode. The neighboring interface is statically configured in trunk mode and will indicate its desire to remain in trunk mode. As a result, the dynamically configured interface on Switch 2 will operate in trunk mode.

Example -6:One interface in dynamic desirable mode and the other interface is configured in static access mode.

SW1(config)#interface fa0/14
SW1(config-if)#switchport mode access

SW2(config)#interface fa0/14
SW2(config-if)#switchport mode dynamic desirable

The interface on Switch 2 is configured in dynamic desirable mode – it will initiate the DTP negotiation to select its operational mode. It will indicate its desire to operate in trunk mode. The neighboring interface is statically configured in access mode and will indicate its desire to remain in access mode. Since the interface on Switch 1 does not agree to operate in trunk mode, the dynamically configured interface on Switch 2 will operate in access mode.

Example -7:One interface in dynamic desirable mode and the other interface in trunk mode.

SW1(config)#interface fa0/14
SW1(config-if)#switchport mode trunk

SW2(config)#interface fa0/14
SW2(config-if)#switchport mode dynamic desirable

The interface on Switch 2 is configured in dynamic desirable mode and it will initiate the DTP negotiation to select its operational mode. It will indicate its desire to operate in trunk mode. The neighboring interface is statically configured in trunk mode and will indicate its desire to remain in trunk mode. Since both interfaces want to operate in trunk mode, the dynamically configured interface on Switch 2 will operate in trunk mode and a trunk link will be formed.

Disabling DTP.

DTP will be disabled per-interface level. Now let’s verify before we disable it.

Switch1(config-if)#do sh int fa0/14 switchport
Name: Fa0/14
Switchport: Enabled
Administrative Mode: trunk
Operational Mode: trunk
Administrative Trunking Encapsulation: dot1q
Operational Trunking Encapsulation: dot1q
Negotiation of Trunking: On

Now you can see above it’s showing that the (Negotiation of Trunking: On). Now let’s disable the DTP and verify.

Switch1(config)#interface fa0/14
Switch1(config-if)#switchport trunk encapsulation dot1q
Switch1(config-if)#switchport mode trunk
Switch1(config-if)#switchport nonegotiate

//Verification//
Switch1(config-if)#do sh int fa0/14 switchport
Name: Fa0/14
Switchport: Enabled
Administrative Mode: trunk
Operational Mode: trunk
Administrative Trunking Encapsulation: dot1q
Operational Trunking Encapsulation: dot1q
Negotiation of Trunking: Off

Now you can see above, it showing that the (Negotiation of Trunking: Off). Now let’s disable the DTP and verify.

Note: in a production network, it’s not recommended to use the DTP.

Leave a Reply

Your email address will not be published.