DNS Redirection to Local DNS Server in Mikrotik..!!..Port 53..!

By | March 26, 2022

Most ISP have their local DNS server hosted in their network instead of using the public DNS server and all the users must use the ISP hosted DNS Server for resolution. So here we will redirect
all our port 53 DNS traffic to our own DNS server. Let’s start the configuration ..!

In Mikrotik for DNS redirection, you have to go to the IP->Firewall->Nat and then
you have to redirect your DNS traffic to your local DNS server and You have to
redirect both TCP and UDP for port 53..!!

Note:-According to the below configuration of mine, The IP 10.1.10.20 in my local
DNS Server IP..!

/ip firewall nat
add action=dst-nat chain=dstnat dst-port=53 protocol=tcp \
    to-addresses=10.1.10.20 to-ports=53
add action=dst-nat chain=dstnat dst-port=53 protocol=udp \
    to-addresses=10.1.10.20 to-ports=53

Leave a Reply

Your email address will not be published.