PPPoE Dial-UP Configuration in Cisco 800 Series Router..!!

By | March 22, 2022

In this post we will see how we will configure the PPPoE client in our 800 series router ,I will do the configuration in CLI, But if you want, you configure through web .

//LAN Interface configuration, Where all my LAN users are connected .My Lan Interfaces are Fa1 and Fa2.
interface FastEthernet1
 switchport access vlan 100
 switchport mode access
 description CONNECTED-TO-LAN@@@@@
 no ip address
!
interface FastEthernet2
 switchport access vlan 100
 description CONNECTED-TO-LAN@@@@@
 switchport mode access
 no ip address
!

//MY WAN Interface configuration which is connected to my ISP modem..!
interface FastEthernet4
 description CONNECTED-TO-ISP-WAN@@@@@
 no ip address
 duplex auto
 speed auto
 pppoe enable group global
 pppoe-client dial-pool-number 1
!

//All my LAN ports are L2 port so i cant configure the IP on port directly so i will configure a interface VLAN and i will configure a IP in that VLAN and my LAN port will me member of that VLAN.

interface Vlan100
 ip address 172.16.40.65 255.255.255.224
 ip nat inside
 ip virtual-reassembly in
!

//Now i have to configure the PPPoE client , Where i will have to configure the username and password given by my ISP . Here, My username is alexa and password 12345678 and the authentication hashing is PAP, Make sure there should not be any invalid credentials configured..!

interface Dialer1
 ip address negotiated
 ip mtu 1492
 ip nat outside
 ip virtual-reassembly in
 encapsulation ppp
 ip tcp adjust-mss 1452
 dialer pool 1
 dialer-group 1
 ppp pap sent-username alexa password 0 12345678
!

//Now i will configure a default route .Its not necessary to create the default route because once the Dial-up will be successful the default route will be created automatically.
!
ip route 0.0.0.0 0.0.0.0 10.10.10.1 name ISP-WAN

!

//Now the final step is to configure the Natting for internet access, so i will configure a ACL where I will match my LAN subnet and i will configure it as PAT
overload .So it means all my users will be Natted on my WAN interface ip .

access-list 3 permit 172.16.40.64 0.0.0.31
ip nat inside source list 3 interface Dialer1 overload
!

Leave a Reply

Your email address will not be published. Required fields are marked *