Trunk & Access Port configuration in Mikrotik switch.!! Model = CRS305-1G-4S+

By | March 10, 2022

I have a CRS switch which is connected to one of my core switch and the link is
connected between my Core and CRS switch is trunk port , From CRS i have 2
customer connected , 1 customer is assigned the vlan 61 and another customer
is assigned vlan 63, and my mgmt vlan is 10 which i will use for managing the
mikrotik remotely .sfp-1 of crs is my trunk port where i will allow all vlans and
sfp 3 and 4 are customer port means i will configure the port as access port of
a specific VLAN .

//Create a Bridge , I have created a Bridge on the name of SW-10.My mgmt vlan is 10 so the PVID must be configured as vlan 10 otherwise you will not be able to access the switch remotely..!!

/interface bridge
add ingress-filtering=yes name=SW-10 pvid=10 vlan-filtering=yes

// Create the VLAN, I have 2 clients so i will create 3 vlan Here including my mgmt VLAN and my mgmt vlan is 10 .And when you are creating the VLAN make sure you have assigned them the bridge port..!!

/interface vlan
add interface=SW-10 name=MGMT vlan-id=10
add interface=SW-10 name=VLAN-63 vlan-id=63
add interface=SW-10 name=Vlan-61 vlan-id=61
//Once you will create the VLAN ,inside the bridge you have to add all your vlan in bridge with respective customers VLAN .sfp-sfpplus1 my trunk port where all vlans are allowed and sfp 3 and 4 are my customer port which is my access port on a particular VLAN .
/interface bridge port
add bridge=SW-10 frame-types=admit-only-vlan-tagged interface=sfp-sfpplus1 pvid=10
add bridge=SW-10 interface=sfp-sfpplus3 pvid=61
add bridge=SW-10 interface=sfp-sfpplus4 pvid=63
//Once you will add the vlans in bridge then change the port type in bridge vlan where you want to configure the port types, tagged or untagged .As sfp 1 my trunk port ,Means i will configure all the vlan as tagged,and sfp 3 is going to be untagged (Access)for customer vlan 61 and the sfp-4 is going to be untagged(Access) for customer vlan 63.
/interface bridge vlan
add bridge=SW-10 tagged=sfp-sfpplus1 untagged=sfp-sfpplus3 vlan-ids=61
add bridge=SW-10 tagged=sfp-sfpplus1 untagged=sfp-sfpplus4 vlan-ids=63
add bridge=SW-10 tagged=sfp-sfpplus1,SW-10 vlan-ids=10
//Add mgmt IP address.
/ip address
add address=10.10.1.41/24 interface=MGMT network=10.100.1.0
//Add a default route towards the gateway if you to manage your mikrotik from remotely..!
/ip route
add distance=1 gateway=10.10.1.10

Leave a Reply

Your email address will not be published.